目 录CONTENT

文章目录

关于openwrt系统安装和学习

Wchh
2022-04-27 / 0 评论 / 0 点赞 / 211 阅读 / 1,193 字

事前准备:
工具:

写入镜像:

  1. 把下载好的镜像解压得到后缀为img的文件,注意gz用7zip解压会报错。推荐使用rar。
  2. 把存储设备删除所有分区,新建一个分区,格式化为EXT4。
  3. 打开镜像写入软件写入img镜像。(写入完成后windows将不能识别该存储设备,提示要格式化,不格式化。)

启动openwrt:

  1. 把存储设备插入主机,开机,设置启动项为该存储设备。
  2. 等待跑代码,根据提示按下enter键。
  3. 如无意外将出现系统LOGO。

设置:
修改/etc/config目录下的network配置文件,更改本机IP。

vi /etc/config/network

将看到以下页面:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option _orig_ifname 'eth0'
        option _orig_bridge 'true'
        option ifname 'eth0 eth1 eth2'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth3'

更改“lan”字段下面的IP地址,设为路由器的网段中的任意一个。
比如:

option ipaddr '192.168.0.55'

0为路由器网段,55为设备标识,你可以设置0-255之间不与其他设备冲突的任意一个数字。
执行重启网卡命令:

service network restart

或者重启主机。
打开windows电脑输入刚设置的IP地址,就可以看到openwrt的界面。
账号密码默认为:

root   password

如果开了passwall国内网卡顿,可关闭物理桥接模式,忽略DHCP选项,在防火墙规则加入一句

iptables -t nat -I POSTROUTING -o eth0 -j MASQUERADE

重启防火墙即可。

0

评论区